Home > Failed To > Failed To Compile Vmmon

Failed To Compile Vmmon

Hizdad 12/09/06 ALinux. The == operator is for arithmetic comarpison not string comparison. Nov 07 23:29:47.941: app-3076605632| Trying to find a suitable PBM set for kernel 3.2.0-4-686-pae. If you need to reset your password, click here. Check This Out

Oct 10 10:49:58.905: app-3076052672| Trying to find a suitable PBM set for kernel 3.0-ARCH. Main Menu LQ Calendar LQ Rules LQ Sitemap Site FAQ View New Posts View Latest Posts Zero Reply Threads LQ Wiki Most Wanted Jeremy's Blog Report LQ Bug Syndicate Latest Re: Failed to compile module vmmon! Sep 02 22:50:07.688: app-3075462848| Trying to find a suitable PBM set for kernel 3.2.0-29-generic-pae. https://communities.vmware.com/thread/344213?tstart=0

Oct 10 10:49:59.525: app-3076052672| Extracting the sources of the vmmon module. Re: Failed to compile module vmmon! Are the guns on a fighter jet fixed or can they be aimed? Thanks @hamedkh –Alejandro Jan 19 '13 at 22:57 Didn't work for me.

  1. another way to run the script is with sudo bash patch-modules_3.2.0.sh Salman 12/09/23 THANK YOU COMMENTS SECTION!!!!
  2. Using default values.
    2016-04-13T07:50:43.555+01:00| vthread-4| I125: DictionaryLoad: Cannot open file "/home/james/.vmware/config": No such file or directory.
    2016-04-13T07:50:43.555+01:00| vthread-4| I125: PREF Optional preferences file not found at /home/james/.vmware/config.
  3. Nov 08 13:57:26.877: app-3076646592| Building module vmmon.
  4. but it sounds like one of your kernel modules is not able to load.

Nov 07 23:29:47.865: app-3076605632| Trying to find a suitable PBM set for kernel 3.2.0-4-686-pae. Cincerely yours, Franz admin 12/09/04 you're going to have to take a look at /tmp/vmware-root/setup-2160.log, the kernel build script output is not terribly useful for diagnostics. linux debian vmware share|improve this question edited Oct 11 '12 at 16:17 asked Oct 11 '12 at 16:06 hamedkh 38121027 Have you upgraded your kernel recently ? –Gilles Quenot brothergrim Jan 26, 2012 6:04 AM (in response to erasmoa) Same thing here.Updated to linux kernel 3.2.1 this morning.

envertain Jan 25, 2012 6:56 AM (in response to erasmoa) Same issue here after uprading to the latest Fedora 16 kernel release;Kernel: 3.2.1-3.fc16.x86_64 #1 SMP Mon Jan 23 15:36:17 UTC 2012 Well, congratulations and thank you very much! pikepenguin Jan 25, 2012 7:55 AM (in response to erasmoa) I got the same thing this morning after updating the kernel last night (Fedora 16, 3.2.1-3.fc16.i686.PAE). I tried on 4.0.1 a cpl days ago and it didn't work.

vBulletin ę2000 - 2017, Jelsoft Enterprises Ltd. Topics: Active | Unanswered Index ┬╗Applications & Desktop Environments ┬╗VMPlayer 3.1.5: Failed to compile module vmmon Pages: 1 #1 2011-10-10 08:59:14 I am Gianluca Member From: London, UK Registered: 2011-05-22 Posts: Updated player to 4.0.2. asked 5 years ago viewed 4643 times active 5 years ago Related 1Kernel module compilation fails when installing vmware tools1VMware Player 4.04 on Ubuntu 12.04 will not compile0Unable to run VMware

I uninstalled gcc-4.7. https://bugs.launchpad.net/bugs/840472 I just migrated to Debian 7.7 and installed VMPlayer 3.1.6. It worked for me. matthausmann Jan 25, 2012 4:44 AM (in response to erasmoa) I've just updated to kernel 3.2.1-3.fc16.x86_64 and I'm seeing the same behaviour.

Oct 10 10:49:58.419: app-3076052672| Trying to find a suitable PBM set for kernel 3.0-ARCH. his comment is here This happens also after installing your patch and also afte uninstallin vmware-player, rebooting the notebook and reinstalling vm + patch. What is the difficulty of an encounter when a monster can transform? It's the only thing that worked at getting VMWare working on my Ubuntu 11.10.

Post your question in this forum. So here is the patch again: diff -u -r source802/vmblock-only/linux/filesystem.c source/vmblock-only/linux/filesystem.c -- source802/vmblock-only/linux/filesystem.c 2012-01-18 22:01:07.000000000 +0100 +++ source/vmblock-only/linux/filesystem.c 2012-04-01 11:48:24.000000000 +0200 @@ -525,7 +525,11 @@ return -EINVAL; } +#if LINUX_VERSION_CODE < Search this Thread 11-08-2014, 05:24 AM #1 lucmove Member Registered: Aug 2005 Location: Brazil Distribution: Debian Jessie Posts: 715 Rep: VMPlayer 3.1.6 - can't compile modules I used to http://arnoldtechweb.com/failed-to/failed-to-compile-module-vmmon-ubuntu-10-10.html Nov 08 13:57:25.531: app-3076646592| Trying to find a suitable PBM set for kernel 3.2.0-4-686-pae.

Nov 07 23:29:47.842: app-3076605632| Trying to find a suitable PBM set for kernel 3.2.0-4-686-pae. modconfig-4393.log 12.9 K Like Show 0 Likes (0) Actions 3. Anyway, 3.1.6 installed, but then it has to compile the modules to work, which it cannot do for some reason.

Nov 08 13:57:25.656: app-3076646592| Trying to find a suitable PBM set for kernel 3.2.0-4-686-pae.

Nov 07 23:29:47.687: app-3076605632| Kernel compiled with: GCC 4.6 Nov 07 23:29:47.687: app-3076605632| Your GCC version: 4.6 Nov 07 23:29:47.819: app-3076605632| Trying to find a suitable PBM set for kernel 3.2.0-4-686-pae. I just downloaded a bunch of updates, including kernel 3.2. Sep 02 22:50:08.690: app-3075462848| Building module with command: /usr/bin/make -C /tmp/vmware-root/modules/vmmon-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/3.2.0-29-generic-pae/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6 Sep 02 22:50:14.306: app-3075462848| Failed to compile module vmmon! Nov 08 13:57:25.851: app-3076646592| Trying to find a suitable PBM set for kernel 3.2.0-4-686-pae.

It supports 32-bit systems, but the processor has to be 64-bit, which I don't have. 4.0 and later flat out refuse to install on my machine. I assume those header patches won't work on 32 bit (yes?) 11.04 vmware share|improve this question edited Jul 17 '11 at 15:12 Jorge Castro 25.9k92391593 asked May 3 '11 at 18:20 Notices Welcome to LinuxQuestions.org, a friendly and active Linux Community. navigate here Fabrice Marcelin (fabricemarcelin) wrote on 2012-03-10: #6 I was not as lucky as you guys, the patch is failing on that step: patch -t -f -p1 < vmware2.6.39fixedv3.patch.

Just wanted to double-check it was not an issue with mismatching -devel.Looks like this is a known problem? The time now is 11:18 PM. You can not post a blank message. The time now is 05:18 PM.

I have installed build-essential, but something else is not working. Click Here to receive this Complete Guide absolutely free. make: Entering directory `/tmp/vmware-root/modules/vmmon-only' make -C /lib/modules/3.0.0-13-generic/build/include/.. Re: Failed to compile module vmmon!